0 Items

If you are using BEYOND 2.0 (Special Launch Edition) please read this page, to ensure you are kept up to date on all software changes and updates that are taking place.

Since the release of BEYOND 2.1, we have segmented the software into it’s three levels (Essentials, Advanced and Ultimate) and we now provide easy upgrade paths for existing QuickShow and LD2000 clients to migrate over to the BEYOND 2.1 software.

How to download and work with BEYOND 2.1+

To begin working with BEYOND 2.1+, clients must first receive an updated BEYOND 2.1+ license file. You can request this license file using the form below. To start the process, upload your existing BEYOND license (using the upload tool below), and let us know from where you purchased the BEYOND software.

After that, our support team will generate a new BEYOND 2.1+ license file for you, enabling you to work with later version of the software. Once you have received the new license file, simply download and install the latest version version of BEYOND 2.1, and you will be up and running.  If you need support when performing this update, simply contact us, and one of our support team members will promptly assist you.

Additional Information for QM2000 Clients working with BEYOND

If you are using QM2000 hardware, BEYOND 2.1+ requires you to use the latest version of LD2000. You can download LD2000 version 5.60 which can be fount on the support page. (The updated license file mentioned above is required for BEYOND 2.1+, whether or not you are using a QM2000.)

How to proceed ?


Let us know where you purchased the software, and send us your BEYOND 2.0 license file.


Tell us the name of the company from where you purchased BEYOND

If you have an invoice or reference number, enter that below

Upload your BEYOND 2.0 license file here: (this should be called License.bmp, found in the C:\BEYOND folder)

Enter your name and email below, where you want us to send your updated license file: